[PR #228] fix: Update PyTorch minimum version to 2.1.0 and improve package interface #228

Open
opened 2026-10-26 21:14:19 +00:00 by bsakaguchi · 0 comments
Owner

📋 Pull Request Information

Original PR: https://github.com/deepseek-ai/Janus/pull/228
Author: @yurekami
Created: 12/25/2025
Status: 🔄 Open

Base: main ← Head: fix/pytorch-version-requirement


📝 Commits (1)

  • 1814452 fix: Update PyTorch minimum version to 2.1.0 and improve init.py

📊 Changes

3 files changed (+6 additions, -5 deletions)

View changed files

📝 janus/__init__.py (+4 -3)
📝 pyproject.toml (+1 -1)
📝 requirements.txt (+1 -1)

📄 Description

Summary

  • Updates PyTorch minimum version from 2.0.1 to 2.1.0
  • Removes unconditional print statement that pollutes stdout
  • Adds __version__ for version tracking

Fixes #220

Problem

The requirements.txt had torch==2.0.1 pinned, but the transformers library requires PyTorch >= 2.1. This caused installation failures:

Disabling PyTorch because PyTorch >= 2.1 is required but found 2.0.1+cu117
None of PyTorch, TensorFlow >= 2.0, or Flax have been found...

Additionally, janus/__init__.py printed a message unconditionally on import:

Python version is above 3.10, patching the collections module.

This polluted stdout and could interfere with output parsing.

Changes

requirements.txt

-torch==2.0.1
+torch>=2.1.0

pyproject.toml

-    "torch>=2.0.1",
+    "torch>=2.1.0",

janus/__init__.py

  • Added __version__ = "1.0.0"
  • Removed print() statement, keeping the compatibility patch with a comment

Test plan

  • Verify Python syntax is valid
  • Verify pyproject.toml is valid
  • Test installation with pip install .
  • Verify import works without stdout pollution

🤖 Generated with Claude Code


🔄 This issue represents a GitHub Pull Request. It cannot be merged through Gitea due to API limitations.

## 📋 Pull Request Information **Original PR:** https://github.com/deepseek-ai/Janus/pull/228 **Author:** [@yurekami](https://github.com/yurekami) **Created:** 12/25/2025 **Status:** 🔄 Open **Base:** `main` ← **Head:** `fix/pytorch-version-requirement` --- ### 📝 Commits (1) - [`1814452`](https://github.com/deepseek-ai/Janus/commit/1814452728522b84678286c6831396850d22f7e8) fix: Update PyTorch minimum version to 2.1.0 and improve __init__.py ### 📊 Changes **3 files changed** (+6 additions, -5 deletions) <details> <summary>View changed files</summary> 📝 `janus/__init__.py` (+4 -3) 📝 `pyproject.toml` (+1 -1) 📝 `requirements.txt` (+1 -1) </details> ### 📄 Description ## Summary - Updates PyTorch minimum version from 2.0.1 to 2.1.0 - Removes unconditional print statement that pollutes stdout - Adds `__version__` for version tracking ## Related Issue Fixes #220 ## Problem The `requirements.txt` had `torch==2.0.1` pinned, but the `transformers` library requires PyTorch >= 2.1. This caused installation failures: ``` Disabling PyTorch because PyTorch >= 2.1 is required but found 2.0.1+cu117 None of PyTorch, TensorFlow >= 2.0, or Flax have been found... ``` Additionally, `janus/__init__.py` printed a message unconditionally on import: ``` Python version is above 3.10, patching the collections module. ``` This polluted stdout and could interfere with output parsing. ## Changes ### `requirements.txt` ```diff -torch==2.0.1 +torch>=2.1.0 ``` ### `pyproject.toml` ```diff - "torch>=2.0.1", + "torch>=2.1.0", ``` ### `janus/__init__.py` - Added `__version__ = "1.0.0"` - Removed `print()` statement, keeping the compatibility patch with a comment ## Test plan - [x] Verify Python syntax is valid - [x] Verify pyproject.toml is valid - [ ] Test installation with `pip install .` - [ ] Verify import works without stdout pollution 🤖 Generated with [Claude Code](https://claude.com/claude-code) --- <sub>🔄 This issue represents a GitHub Pull Request. It cannot be merged through Gitea due to API limitations.</sub>
Sign in to join this conversation.
No labels
pull-request
No milestone
No project
No assignees
1 participant
Notifications
Due date
The due date is invalid or out of range. Please use the format "yyyy-mm-dd".

No due date set.

Dependencies

No dependencies set.

Reference
deepseek-ai/Janus#228
No description provided.