[PR #230] [CLOSED] fix: update PyTorch version requirement to >=2.1.0 #230

Closed
opened 2026-10-26 21:14:22 +00:00 by bsakaguchi · 0 comments
Owner

📋 Pull Request Information

Original PR: https://github.com/deepseek-ai/Janus/pull/230
Author: @Mr-Neutr0n
Created: 2/6/2026
Status: ❌ Closed

Base: main ← Head: fix-requirements-pytorch-version


📝 Commits (1)

  • 26a22ce fix: update PyTorch version requirement to >=2.1.0

📊 Changes

1 file changed (+1 additions, -1 deletions)

View changed files

📝 requirements.txt (+1 -1)

📄 Description

Summary

  • Updated torch==2.0.1 to torch>=2.1.0 in requirements.txt

Problem

transformers>=4.38.2 requires PyTorch >= 2.1, but the requirements.txt specified torch==2.0.1. This caused installation failures with error:

Disabling PyTorch because PyTorch >= 2.1 is required but found 2.0.1+cu117

Solution

Changed the torch version constraint from exact version 2.0.1 to minimum version >=2.1.0 to satisfy transformers dependency.

Fixes #220


🔄 This issue represents a GitHub Pull Request. It cannot be merged through Gitea due to API limitations.

## 📋 Pull Request Information **Original PR:** https://github.com/deepseek-ai/Janus/pull/230 **Author:** [@Mr-Neutr0n](https://github.com/Mr-Neutr0n) **Created:** 2/6/2026 **Status:** ❌ Closed **Base:** `main` ← **Head:** `fix-requirements-pytorch-version` --- ### 📝 Commits (1) - [`26a22ce`](https://github.com/deepseek-ai/Janus/commit/26a22ce4f35f4442ca5a322633f8c212fa51b3fd) fix: update PyTorch version requirement to >=2.1.0 ### 📊 Changes **1 file changed** (+1 additions, -1 deletions) <details> <summary>View changed files</summary> 📝 `requirements.txt` (+1 -1) </details> ### 📄 Description ## Summary - Updated `torch==2.0.1` to `torch>=2.1.0` in requirements.txt ## Problem `transformers>=4.38.2` requires PyTorch >= 2.1, but the requirements.txt specified `torch==2.0.1`. This caused installation failures with error: ``` Disabling PyTorch because PyTorch >= 2.1 is required but found 2.0.1+cu117 ``` ## Solution Changed the torch version constraint from exact version `2.0.1` to minimum version `>=2.1.0` to satisfy transformers dependency. Fixes #220 --- <sub>🔄 This issue represents a GitHub Pull Request. It cannot be merged through Gitea due to API limitations.</sub>
bsakaguchi 2026-10-26 21:14:22 +00:00
Sign in to join this conversation.
No labels
pull-request
No milestone
No project
No assignees
1 participant
Notifications
Due date
The due date is invalid or out of range. Please use the format "yyyy-mm-dd".

No due date set.

Dependencies

No dependencies set.

Reference
deepseek-ai/Janus#230
No description provided.